Aprova o regulamento relativo à disponibilização da informação sobre a localização do chamador ao Ponto de Atendimento de Segurança Pública.
Objeto
O presente regulamento estabelece:
Âmbito
Ao abrigo do disposto nos n.os 2 e 6 do artigo 67.º da Lei das Comunicações Eletrónicas, aprovada pela Lei n.º 16/2022, de 16 de agosto, devem cumprir com as disposições do presente regulamento:
Siglas, acrónimos e definições
Cooperação
As empresas referidas no artigo 2.º devem cooperar entre si e com as autoridades competentes pelos serviços de emergência, com vista a disponibilizar ao PASP mais adequado a informação mais precisa e fiável sobre a localização do chamador, no respeito pela legislação e enquadramento vigentes.
Princípios e regras gerais
Para efeitos da execução dos n.os 2 e 6 do artigo 67.º da LCE, as empresas referidas no artigo 2.º, devem:
Princípios e regras específicas
Código de empresa
Número de encaminhamento
Para efeitos da execução da alínea a) do n.º 2 do artigo 67.º da LCE, as empresas referidas na alínea a) do artigo 2.º, devem:
Informação sobre a localização do chamador
Utilizadores finais que não sejam consumidores
As empresas referidas na alínea a) do artigo 2.º, quando são responsáveis pela configuração e gestão das extensões telefónicas dos seus utilizadores finais que não sejam consumidores, devem:
Disponibilização da informação sobre a localização do chamador
Dispositivo móvel
AML e eCall
As empresas referidas no artigo 2.º, quando aplicável, devem assegurar:
Precisão e fiabilidade
Subcontratação e acesso à rede móvel
Fiscalização
Compete à ANACOM a fiscalização do cumprimento do disposto no presente regulamento.
Regime sancionatório
As infrações ao disposto no presente regulamento são puníveis nos termos da alínea v) do n.º 3 do artigo 178.º da LCE.
Norma revogatória
É revogado o Regulamento n.º 99/2009, de 23 de fevereiro.
Entrada em vigor e disposição transitória
1 - O presente regulamento entra em vigor 12 meses após a sua publicação no Diário da República, sem prejuízo do disposto nos números seguintes.
2 - As empresas referidas na alínea a) do artigo 2.º, no que se refere às comunicações de emergência efetuadas através da rede pública fixa, da rede pública móvel no caso do 2G e 3G, e da Internet pública, devem disponibilizar ao PASP mais adequado a informação sobre a localização do chamador nos termos do presente regulamento, no prazo máximo de 6 meses a contar da data da entrada em vigor do presente regulamento.
3 - Para efeitos do número anterior e até à disponibilização ao PASP mais adequado da informação sobre a localização do chamador nos termos do presente Regulamento, as empresas referidas na alínea a) do artigo 2.º devem cumprir para o efeito o disposto no Regulamento n.º 99/2009, de 23 de fevereiro.
13 de agosto de 2024. - A Presidente do Conselho de Administração, Sandra Marisa Santas Noites Maximiano.
ANEXO I
Especificação técnica
As comunicações de emergência apresentam especificidades, no que diz respeito à configuração das mensagens de sinalização e características que não se encontram nas outras formas de comunicação, como, por exemplo, a informação sobre a localização do chamador e a identificação da linha chamadora, que devem ser mantidas durante o encaminhamento dessa comunicação.
Para esse efeito, o presente anexo especifica os aspetos relativos às comunicações de emergência no que se refere à informação que deve ser transportada no Session Initiation Protocol (SIP), sem prejuízo do que consta nas normas técnicas e recomendação aplicáveis, nomeadamente ETSI TS 103 479 e ETSI ES 203 283, bem como à informação sobre a localização do chamador que deve ser transportada em SIP e codificada utilizando o Presence Information Data Format - Location Object.
1 - Siglas e acrónimos
a) 3GPP - 3rd Generation Partnership Project;
b) ANACOM - Autoridade Nacional de Comunicações;
c) ETSI - European Telecommunications Standards Institute;
d) GML - Geography Markup Language;
e) IETF - Internet Engineering Task Force;
f) IMEI - International Mobile Equipment Identity;
g) PASP - Ponto de Atendimento de Segurança Pública;
h) PIDF-LO - Presence Information Data Format - Location Object;
i) PNN - Plano Nacional de Numeração;
j) PTR - Ponto de Terminação de Rede;
k) RFC - Request for Comments;
l) SIP - Session Initiation Protocol;
m) TS - Technical Specification;
n) URI - Uniform Resource Identifier;
o) URN - Uniform Resource Name;
p) XML - Extensible Markup Language;
q) VoWiFi - Voice over WiFi.
2 - SIP
O protocolo SIP deve ser utilizado no estabelecimento da comunicação de emergência com o PASP mais adequado, bem como na disponibilização, ao PASP mais adequado, da informação sobre a localização do chamador.
Sem prejuízo do que consta nas normas técnicas e nas melhores práticas aplicáveis a esta matéria, a informação prevista nos pontos 2.1 a 2.5 deve ser transportada de acordo com o referido nesses pontos.
2.1 - Identificação da Empresa
O código de empresa deve ser transportado no ‘SIP header’ "Organization" (RFC 3261) o qual deve ser inserido no ‘SIP request’ "INVITE".
2.2 - Número de encaminhamento
2.2.1 - Formato
O formato do número de encaminhamento é definido da seguinte forma:
Tabela I-1: Formato do número de encaminhamento
Código de País
Número de emergência
Tipo de comunicação
Área geográfica
+351
abc
Z
xy
Onde:
a) O campo ‘abc’ é referente ao número de emergência para onde a comunicação de emergência é efetuada, salvo indicação em contrário pelas autoridades competentes pelos serviços de emergência.
b) O campo ‘Z’ é referente ao tipo de comunicação de emergência:
i) Z = ‘2’, no caso de uma chamada;
ii) Z = ‘6’, no caso de uma chamada eCall manual; e
iii) Z = ‘7’, no caso de uma chamada eCall automática.
c) O campo ‘xy’ é referente à área geográfica onde a comunicação de emergência é originada, correspondendo aos últimos dois dígitos das gamas ‘2xy’ do PNN, com exceção de:
i) xy = ‘00’, caso não seja possível determinar a área geográfica onde a comunicação de emergência foi originada ou garantir a fidedignidade da informação sobre a localização do chamador;
ii) xy = ‘10’, caso a comunicação de emergência seja originada na área geográfica de Lisboa; e
iii) xy = ‘20’, caso a comunicação de emergência seja originada na área geográfica do Porto.
Notas
• Relativamente à alínea a), o campo ‘abc’ corresponde ao número único europeu de emergência ‘112’ ou qualquer outro número nacional de emergência especificado pela ANACOM, devidamente identificado no PNN;
• Relativamente à alínea c), no caso de áreas geográficas com mais do que uma gama de numeração, o campo ‘xy’ deve corresponder aos últimos dois dígitos de qualquer uma das respetivas gamas. Por exemplo, no caso da área geográfica de Braga o campo ‘xy’ deve corresponder a ‘53’ ou a ‘57’.
2.2.2 - Transporte
O número de encaminhamento deve ser transportado no "Request-URI" do ‘SIP request’ "INVITE", de acordo com o formato da Tabela I-1. Nos casos em que o dispositivo inicia a comunicação de emergência com "Request-URI" contendo o URN do serviço, por exemplo, “urn:service:sos”, este deve ser substituído pelo número de encaminhamento.
O formato do "Request-URI" deve ser ‘TEL URI’ (RFC3966) ou ‘SIP URI’ com indicação de “user=phone” (RFC3261).
2.3 - Identificação da linha chamadora
A identificação da linha chamadora deve ser transportada no ‘SIP header’ "P-Asserted-Identity" (RFC 3325) o qual deve ser inserido no ‘SIP request’ "INVITE", quando a rede onde a comunicação de emergência foi originada autenticou o utilizador final, sem prejuízo do que consta nos ‘SIP header’ "From" ou "P-Preferred-Identity".
A identificação da linha chamadora deve corresponder ao número do plano nacional ou internacional de numeração validado pela rede e a partir do qual é efetuada a comunicação de emergência.
Nos casos em que a rede onde a comunicação de emergência foi originada não autenticou o utilizador final, o ‘SIP header’ "P-Asserted-Identity" não deve ser inserido no ‘SIP request’ "INVITE".
2.4 - IMEI
O IMEI do dispositivo móvel deve ser transportado no parâmetro instance-id na forma de IMEI URN (RFC 7254) do ‘SIP header’ "Contact" o qual deve ser inserido no ‘SIP request’ "INVITE". O formato do instance-id deve tomar a forma de “urn:gsma:imei:”, onde o imeival corresponde ao IMEI do dispositivo móvel.
O IMEI do dispositivo móvel a partir do qual é efetuada a comunicação de emergência pode ser:
a) Disponibilizado pelo dispositivo, de acordo com o previsto anteriormente (3GPP TS 23.003);
b) Obtido através da rede, quando a rede tem essa capacidade, devendo, caso o dispositivo móvel não o tenha disponibilizado, ser transportado de acordo com o previsto anteriormente.
2.5 - Cell-info-age
O cell-info-age referente à última célula a que o dispositivo móvel esteve registado ou ligado, quando a comunicação de emergência é originada através de outro meio de acesso que não a rede pública móvel, como é o caso de VoWiFi, deve ser transportado no parâmetro cell-info-age do ‘SIP header’ "Cellular-Network-Info" o qual deve ser inserido no ‘SIP request’ "INVITE". O cell-info-age corresponde ao tempo, em segundos, decorrido desde que o dispositivo móvel esteve registado ou ligado a essa última célula.
O cell-info-age pode ser:
a) Disponibilizado pelo dispositivo, de acordo com o previsto anteriormente (TS 124 229);
b) Obtido através da rede, devendo, caso o dispositivo móvel não o tenha disponibilizado, ser transportado de acordo com o referido anteriormente.
3 - Informação sobre a localização do chamador
A informação sobre a localização do chamador corresponde aos dados tratados numa rede pública móvel provenientes da infraestrutura da rede ou do dispositivo móvel, que indicam a posição geográfica do equipamento terminal móvel de um utilizador final e, numa rede pública fixa, os dados sobre o endereço físico do PTR.
3.1 - Disponibilização da informação (PIDF-LO)
Os dados referentes à informação sobre a localização do chamador, devem ser transportados por valor (Location-by-Value) no ‘SIP body’ e devem ser codificados utilizando o PIDF-LO (RFC 4119 e RFC 5491) onde o formato é baseado em XML (RFC 3863).
Quando a informação sobre a localização do chamador é disponibilizada, esta deve ser transportada nos ‘SIP request’ (por exemplo "INVITE", "re-INVITE" ou "UPDATE") devendo o ‘SIP header’ "Geolocation" (RFC 6442) ser inserido contendo a referência content id (cid) (RFC 2392) correspondente ao "Content-ID" do ‘SIP body’, onde se encontram os respetivos dados.
3.2 - Endereço físico
A informação sobre a localização do chamador quando corresponde aos dados sobre o endereço físico, nomeadamente do PTR, esses dados devem ser representados no PIDF-LO como do tipo "civic", tendo em conta o previsto nos pontos 3.2.1 e 3.2.2.
Os dados relativos ao endereço físico e a estrutura do XML que contém esses dados, devem ser codificados de acordo com o RFC 4119 e o RFC 5139.
3.2.1 - Endereço físico - Geral
A informação sobre o endereço físico deve ser a mais completa possível de forma a permitir identificar com precisão a localização do chamador. Nesse sentido, são definidos na Tabela I-2 os dados mínimos que devem ser disponibilizados ao PASP mais adequado e a respetiva "label" onde devem constar.
Tabela I-2: Dados mínimos
Dado
"label" de acordo com os RFC 4119 e RFC 5139
Localidade
A3
Morada
A6
Sufixo da morada
STS
Número de porta
HNO
Código postal
PC
Designação postal
PCN
Em complemento aos dados anteriores, devem, quando aplicável, ser disponibilizados ao PASP mais adequado os dados que constam na Tabela I-3 e a respetiva "label" onde devem constar, de acordo com os referidos RFC.
Tabela I-3: Dados adicionais
Dado
"label" de acordo com os RFC 4119 e RFC 5139
Sufixo do número de porta
HNS
Andar
FLR
Apartamento
UNIT
Edifício
BLD
Entidade, empresa ou estabelecimento
NAM
Sem prejuízo destes dados, podem ser disponibilizados ao PASP mais adequado dados adicionais, de acordo com os referidos RFC, que permitam uma melhor localização do chamador, salvo eventual incompatibilidade com os sistemas do PASP.
3.2.2 - Endereço físico - Informação complementar
Em complemento aos dados referidos no ponto anterior, devem, quando disponível e aplicável (por exemplo, no caso de extensões telefónicas), ser disponibilizados ao PASP mais adequado os dados que constam na Tabela I-4 e a respetiva "label" onde devem constar, de acordo com os referidos RFC.
Tabela I-4: Dados complementares
Dado
"label" de acordo com os RFC 4119 e RFC 5139
Edifício
BLD
Tipo de local
PLC
Andar
FLR
Sala
LOC
Quarto
ROOM
Local de trabalho
SEAT
Sem prejuízo destes dados, podem ser disponibilizados ao PASP mais adequado, dados adicionais, de acordo com os referidos RFC, que permitam uma melhor localização do chamador, salvo eventual incompatibilidade com os sistemas do PASP.
3.3 - Infraestrutura da rede pública móvel
A informação sobre a localização do chamador quando corresponde aos dados provenientes da infraestrutura da rede pública móvel, ou seja, à célula onde a comunicação de emergência é originada, esses dados devem ser representados no PIDF-LO como do tipo "Geodetic" através da forma geométrica (Geodetic Shape Representation) "arcband" (RFC 5491).
Os dados provenientes da infraestrutura da rede pública móvel devem ser representados de acordo com o previsto no ponto 3.3.1, exceto quando as empresas dispõem de capacidade para determinar a área dentro da respetiva célula onde o equipamento terminal está localizado, nomeadamente através do Timing Advance, devendo nesses casos ser representados de acordo com o previsto no ponto 3.3.2.
3.3.1 - Sector
Esta forma geométrica permite através da representação da área de cobertura teórica da respetiva célula, obter a área onde o equipamento terminal móvel está localizado (Figura I-1).
Figura I-1: Sector.
Para esse efeito, os dados, indicados na figura, são os seguintes:
i) a(s) - ângulo inicial da célula relativo ao norte geográfico;
ii) a(o) - ângulo de abertura da célula;
iii) r(o) - raio teórico da célula;
iv) r(i) - 0 metros;
v) c - localização da célula.
Os dados relativos ao "sector" e a estrutura do XML que contém esses dados, devem ser determinados e codificados de acordo com a forma geométrica (Geodetic Shape Representation) "arcband", ou seja, de acordo com o RFC 5491 e o "GML 3.1.1 PIDF-LO Shape Application Schema for use by the Internet Engineering Task Force (IETF)".
3.3.2 - Arcband
Esta forma geométrica permite através da representação de um raio interior - r(i) - e de um raio exterior - r(o) - indicar a área, dentro da respetiva célula, onde o equipamento terminal móvel está localizado (Figura I-2).
Figura I-2: Arcband.
Para esse efeito, os dados, indicados na figura, são, os seguintes:
i) a(s) - ângulo inicial da célula relativo ao norte geográfico;
ii) a(o) - ângulo de abertura da célula;
iii) r(o) - distância máxima do equipamento terminal móvel ao ponto c;
iv) r(i) - distância mínima do equipamento terminal móvel ao ponto c;
v) c - localização da célula.
Os dados relativos ao "arcband" e a estrutura do XML que contém esses dados, devem ser determinados e codificados de acordo com o RFC 5491 e o "GML 3.1.1 PIDF-LO Shape Application Schema for use by the Internet Engineering Task Force (IETF)".
3.4 - VoWiFi
Quando a comunicação de emergência é originada em VoWiFi, os dados provenientes da infraestrutura da rede pública móvel devem corresponder aos dados da última célula a que o dispositivo móvel esteve registado ou ligado e devem ser representados de acordo com o previsto no ponto 3.3.1.
Por se tratar de informação relativa à última célula, deve ser incluída informação sobre o tempo decorrido desde que o dispositivo móvel esteve registado ou ligado a essa última célula, de acordo com o previsto no ponto 2.5.
3.5 - Coordenadas geográficas
Quando a informação sobre a localização do chamador corresponde a coordenadas geográficas, os respetivos dados devem ser representados no PIDF-LO como do tipo "Geodetic" através da forma geométrica (Geodetic Shape Representation) "point" (RFC 5491).
Os dados relativos às coordenadas geográficas e a estrutura do XML que contém esses dados devem ser determinados e codificados de acordo com o RFC 5491 e o "GML 3.1.1 PIDF-LO Shape Application Schema for use by the Internet Engineering Task Force (IETF)".
ANEXO II
Especificação técnica - Informação complementar
Este anexo especifica a informação complementar sobre a localização do chamador, proveniente da infraestrutura da rede pública móvel, e a solução relativa à sua disponibilização ao Ponto de Atendimento de Segurança Pública (PASP) mais adequado. Esta informação é complementar à referida no Anexo I, de modo a providenciar ao PASP redundância para que, em caso de uma eventual falha (por exemplo, do Presence Information Data Format Location Object - PIDF-LO - ou da arquitetura Next Generation 112), possa assim manter a capacidade de obter a posição geográfica do equipamento terminal móvel do utilizador final (por exemplo, recorrer à arquitetura anterior).
1 - Siglas e acrónimos
a) SIP - Session Initiation Protocol;
b) WGS84 - World Geodetic System 1984.
2 - Informação sobre a localização do chamador
A informação sobre a localização do chamador corresponde aos dados tratados numa rede pública móvel provenientes da infraestrutura da rede ou do dispositivo móvel, que indicam a posição geográfica do equipamento terminal móvel de um utilizador final e, numa rede pública fixa, os dados sobre o endereço físico do ponto de terminação de rede.
2.1 - Disponibilização da informação
Os dados referentes à informação sobre a localização do chamador, devem ser transportados no ‘SIP header’ "diversion" ou "history-info" (dependendo da opção da empresa que disponibiliza a informação) o qual deve ser inserido no ‘SIP request’ "INVITE" e devem ser codificados no seguinte formato FFGGMMSSggmmssRR.
A Tabela II-1 detalha cada um dos campos do respetivo formato.
Tabela II-1: Formato
Descrição
Campo
Significado/Componente
Código de identificação do operador móvel
FF
Valores possíveis: 00 a 99, em que:
11 - NOS Comunicações, S. A. (NOS)
12 - MEO - Serviços de Comunicações e Multimédia, S. A. (MEO)
13 - Vodafone Portugal - Comunicações Pessoais, S.A (Vodafone)
99 - Outros operadores móveis
Localização da célula
GG
Graus
Latitude
MM
Minutos
SS
Segundos
gg
Graus
Longitude
mm
Minutos
ss
Segundos
Raio teórico da célula
RR
Dimensão e forma da incerteza
Valores possíveis: 00 a 99
2.2 - Infraestrutura da rede pública móvel
A informação sobre a localização do chamador quando corresponde aos dados provenientes da infraestrutura da rede pública móvel, ou seja, à célula onde a comunicação de emergência é originada ou, no caso de VoWiFi à última célula onde o dispositivo móvel esteve registado ou ligado, esses dados devem ser representados através da forma geométrica de um "círculo" (Figura II-1).
Figura II-1: Representação geométrica do tipo círculo.
Para esse efeito, os dados, indicados na figura, são, os seguintes:
• r - raio teórico da célula;
• c - localização da célula, expressa em coordenadas geográficas, codificada de acordo com a norma WGS84.
O raio teórico da célula indica a dimensão e forma da incerteza, devendo o valor desse raio ser codificado de acordo com os valores de RR que constam na tabela do respetivo operador móvel que disponibiliza a informação (Tabela II-2).
Tabela II-2: Valores do RR
NOS e Vodafone
MEO e outros operadores móveis
RR
Raio
RR
Raio
00
< 100 m
00
< 100 m
01
< 250 m
01
< 250 m
02
< 500 m
02
< 500 m
03
< 1 km
03
< 750 m
04
< 2 km
04
< 1 km
05
< 4 km
05
< 2 km
06
< 10 km
06
< 4 km
07
< 20 km
07
< 10 km
08
< 30 km
08
< 20 km
09
> 30 km
09
> 20 km
ANEXO III
Critérios de precisão e de fiabilidade
Este anexo estabelece os critérios de precisão e de fiabilidade da informação sobre a localização do chamador aplicáveis às comunicações de emergência efetuadas através da rede pública fixa, da rede pública móvel e da Internet pública.
1 - Siglas e acrónimos
a) PASP - Ponto de Atendimento de Segurança Pública;
b) PTR - Ponto de Terminação de Rede.
2 - Rede pública fixa
2.1 - Critério de precisão
Na rede pública fixa, o critério de precisão da informação sobre a localização do chamador deve ser expresso sob a forma de informação relacionada com o endereço físico do PTR.
Nesse sentido, é estabelecido que o critério de precisão da informação sobre a localização do chamador, corresponde aos dados sobre o endereço físico do PTR, de acordo com o previsto no ponto 3.2 do Anexo I.
2.2 - Critério de fiabilidade
Na rede pública fixa, o critério de fiabilidade da informação sobre a localização do chamador deve ser expresso em termos de taxa de sucesso, em percentagem, da solução técnica ou da combinação de soluções técnicas no estabelecimento e na transmissão ao PASP mais adequado da informação sobre a localização do chamador correspondente ao critério de precisão.
Neste sentido, é estabelecido que o critério de fiabilidade deve ser de 95 %, significando que no mínimo em 95 % das comunicações de emergência originadas na rede pública fixa, a informação sobre a localização do chamador corresponde ao critério de precisão estabelecido no ponto anterior.
3 - Rede pública móvel
3.1 - Critério de precisão
Na rede pública móvel, o critério de precisão da informação sobre a localização do chamador deve ser expresso em metros para indicar o raio máximo da área de busca horizontal.
Nesse sentido, é estabelecido que o critério de precisão da informação sobre a localização do chamador corresponde, no máximo, a 100 metros.
Quando a oferta do serviço se refere ao serviço telefónico em local fixo, o critério de precisão corresponde ao estabelecido no ponto 2.1.
3.2 - Critério de fiabilidade
Na rede pública móvel, o critério de fiabilidade da informação sobre a localização do chamador deve ser expresso em termos de taxa de sucesso, em percentagem, da solução técnica ou da combinação de soluções técnicas no estabelecimento e na transmissão ao PASP mais adequado de uma área de busca correspondente ao critério de precisão.
Neste sentido, é estabelecido que o critério de fiabilidade deve ser de 60 %, significando que no mínimo em 60 % das comunicações de emergência originadas na rede pública móvel, a informação sobre a localização do chamador corresponde ao critério de precisão estabelecido no ponto anterior, tendo em conta a combinação dos dados provenientes do dispositivo móvel e dos dados provenientes da infraestrutura da rede pública móvel, de acordo com o previsto no ponto 3.3 do Anexo I e do ponto 2.2 do Anexo II.
Quando a oferta do serviço se refere ao serviço telefónico em local fixo, o critério de fiabilidade corresponde ao estabelecido no ponto 2.2.
4 - Internet pública
4.1 - Critério de precisão
Na Internet pública, o critério de precisão da informação sobre a localização do chamador deve ser expresso sob a forma de informação relacionada com o endereço físico do PTR ou de faturação associado ao serviço do número que efetua a comunicação de emergência.
Nesse sentido, é estabelecido que o critério de precisão da informação sobre a localização do chamador, corresponde aos dados sobre o endereço físico do PTR ou de faturação associado ao serviço do número que efetua a comunicação de emergência, de acordo com o previsto no ponto 3.2 do Anexo I.
4.2 - Critério de fiabilidade
Na Internet pública, o critério de fiabilidade da informação sobre a localização do chamador deve ser expresso em termos de taxa de sucesso, em percentagem, da solução técnica ou da combinação de soluções técnicas no estabelecimento e na transmissão ao PASP mais adequado da informação sobre a localização do chamador correspondente ao critério de precisão.
Neste sentido, é estabelecido que o critério de fiabilidade deve ser de 95 %, significando que no mínimo em 95 % das comunicações de emergência originadas na Internet pública, a informação sobre a localização do chamador corresponde ao critério de precisão estabelecido no ponto anterior.
318026261